Curve3dGetTrimmedOffset(Double,
Vector3d, OffsetCurveExtensionType)
Method
|
Receives one or more offset curves that
represent the trimmed offset of the curve.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Curve3d[] GetTrimmedOffset(
double distance,
Vector3d planeNormal,
OffsetCurveExtensionType extensionType
)
Public Function GetTrimmedOffset (
distance As Double,
planeNormal As Vector3d,
extensionType As OffsetCurveExtensionType
) As Curve3d()
public:
array<Curve3d^>^ GetTrimmedOffset(
double distance,
Vector3d planeNormal,
OffsetCurveExtensionType extensionType
)
member GetTrimmedOffset :
distance : float *
planeNormal : Vector3d *
extensionType : OffsetCurveExtensionType -> Curve3d[]
Parameters
- distance Double
- [in] Offset distance.
- planeNormal Vector3d
- [in] A normal to the plane of this curve.
- extensionType OffsetCurveExtensionType
- [in] Determines how the offset curve will be extended at points
of C1 discontinuity.
Return Value
Curve3d
Array that stores offset curves.
See Also