GeometryCircle(Point3d, Point3d,
Point3d) Method
|
Introduces a circle to the vectorization
context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Circle(
Point3d firstPoint,
Point3d secondPoint,
Point3d thirdPoint
)
Public MustOverride Function Circle (
firstPoint As Point3d,
secondPoint As Point3d,
thirdPoint As Point3d
) As Boolean
public:
virtual bool Circle(
Point3d firstPoint,
Point3d secondPoint,
Point3d thirdPoint
) abstract
abstract Circle :
firstPoint : Point3d *
secondPoint : Point3d *
thirdPoint : Point3d -> bool
Parameters
- firstPoint Point3d
- [in] First point of a 3-point circle.
- secondPoint Point3d
- [in] Second point of a 3-point circle.
- thirdPoint Point3d
- [in] Third point of a 3-point circle.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
Remarks
firstPoint,
secondPoint, and thirdPoint cannot be colinear and no two can be
coincident.
See Also