CubicSplineCurve2d(KnotCollection,
Point2dCollection, Vector2dCollection,
Boolean) Constructor
|
Constructor for the CubicSplineCurve2d class.
Creates a cubic spline curve according to the passed
parameters.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CubicSplineCurve2d(
KnotCollection knots,
Point2dCollection fitPoints,
Vector2dCollection firstDerivatives,
bool periodic
)
Public Sub New (
knots As KnotCollection,
fitPoints As Point2dCollection,
firstDerivatives As Vector2dCollection,
periodic As Boolean
)
public:
CubicSplineCurve2d(
KnotCollection^ knots,
Point2dCollection^ fitPoints,
Vector2dCollection^ firstDerivatives,
bool periodic
)
new :
knots : KnotCollection *
fitPoints : Point2dCollection *
firstDerivatives : Vector2dCollection *
periodic : bool -> CubicSplineCurve2d
Parameters
- knots KnotCollection
- [in] Knot vector.
- fitPoints Point2dCollection
- [in] Array of fit points.
- firstDerivatives Vector2dCollection
- [in] Array of first derivatives at the fit points.
- periodic Boolean
- [in] Flag that specifies whether a cubic spline curve should be
periodic (closed).
See Also