CubicSplineCurve2d Constructor

Overload List
  Name Description
Public method CubicSplineCurve2d Default constructor for the CubicSplineCurve2d class. Creates a cubic spline curve with no actual data.
Public method CubicSplineCurve2d(Point2dCollection) Constructor for the CubicSplineCurve2d class. Creates a cubic spline curve with the passed fit points.
Public method CubicSplineCurve2d(Curve2d, Double) Constructor for the CubicSplineCurve2d class. Creates a cubic spline curve with the passed fit curve.
Public method CubicSplineCurve2d(Point2dCollection, Tolerance) Constructor for the CubicSplineCurve2d class. Creates a cubic spline curve with the passed fit points.
Public method CubicSplineCurve2d(Point2dCollection, Vector2d, Vector2d) Constructor for the CubicSplineCurve2d class. Creates a cubic spline curve with the passed start and end derivatives, and fit points.
Public method CubicSplineCurve2d(KnotCollection, Point2dCollection, Vector2dCollection, Boolean) Constructor for the CubicSplineCurve2d class. Creates a cubic spline curve according to the passed parameters.
Public method CubicSplineCurve2d(Point2dCollection, Vector2d, Vector2d, Tolerance) Constructor for the CubicSplineCurve2d class. Creates a cubic spline curve according to the passed parameters.
Top
See Also