MaterialNormalMapComponent Constructor

Constructor for the MaterialNormalMapComponent class. Constructs an object with the specified material map, method used to compute the normal map and the channel strength.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public MaterialNormalMapComponent(
        MaterialMap map,
        NormalMapMethod method,
        double strength
)

Parameters

map  MaterialMap
[in] Material map.
method  NormalMapMethod
[in] Method used to compute the normal map.
strength  Double
[in] Strength of the normal map.
See Also

©  Bricsys NV. All rights reserved.