MaterialMap Class

This class implements material maps. Material maps define bitmapped images that are applied to object surfaces.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceMaterialMap

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class MaterialMap : RXObject

The MaterialMap type exposes the following members.

Constructors
  Name Description
Public method MaterialMap Default constructor for the MaterialMap class. Creates a material map with a file source and blend factor of 1.0.
Public method MaterialMap(Source, MaterialTexture, Double, Mapper) Constructor for the MaterialMap class. Creates a map from the specified source, with a material texture, blend factor and mapper.
Public method MaterialMap(Source, String, MaterialTexture, Double, Mapper) Constructor for the MaterialMap class. Creates a map from the specified source that includes a file path (if source is File), with a material texture, blend factor, and mapper.
Public method MaterialMap(Source, MaterialTexture, Double, Mapper, MapFilter) Constructor for the MaterialMap class. Creates a map from the specified source, with a material texture, blend factor, mapper and map filter.
Top
Properties
  Name Description
Public property BlendFactor  
Public property Filter Property that represents a map filter for this material map. Currently map filters are not supported.
Public property Mapper Property that represents a mapper associated with this material map.
Public property Source  
Public property SourceFileName  
Public property Texture Property that represents a texture associated with this material map.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides DisposableWrapperEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides DisposableWrapperGetHashCode)
Top
Operators
  Name Description
Public operatorStatic member Equality(MaterialMap, MaterialMap) Equality operator for the MaterialMap structure. Checks whether input normal map components are equal.
Public operatorStatic member Inequality(MaterialMap, MaterialMap) Inequality operator for the MaterialMap structure. Checks whether input normal map components are equal.
Top
See Also

©  Bricsys NV. All rights reserved.