LayerStateManagerSaveLayerState Method
|
Saves a layer state to the current
database.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SaveLayerState(
string name,
LayerStateMasks mask,
ObjectId id
)
Public Sub SaveLayerState (
name As String,
mask As LayerStateMasks,
id As ObjectId
)
public:
void SaveLayerState(
String^ name,
LayerStateMasks mask,
ObjectId id
)
member SaveLayerState :
name : string *
mask : LayerStateMasks *
id : ObjectId -> unit
Parameters
- name String
- [in] Name of the layer state to save.
- mask LayerStateMasks
- [in] Layer state mask.
- id ObjectId
- [in] Object ID of the viewport for which to save the layer
state.
Remarks
A layer state mask
determines which layer attributes to store in the layer state. A
layer state mask must be a combination of one or more of the
following: NameValueNone 0x0000 On 0x0001 Frozen 0x0002 Locked
0x0004 Plot 0x0008 NewViewport 0x0010 Color 0x0020 LineType 0x0040
LineWeight 0x0080 PlotStyle 0x0100 CurrentViewport 0x0200
Transparency 0x0400
See Also