LayerStateManager Class

This class represents Layer State Manager objects. The LayerStateManager object can access and manage individual layer states associated with a database.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesLayerStateManager

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class LayerStateManager : RXObject

The LayerStateManager type exposes the following members.

Constructors
  Name Description
Public method LayerStateManager Constructor for the LayerStateManager class. Creates a LayerStateManager object from the specified database.
Top
Properties
  Name Description
Public property LastRestoredLayerState Property that represents the last restored layer state. Currently not implemented.
Top
Methods
  Name Description
Public method CompareLayerStateToDb Compares a specified layer state to the layer state associated with a specified viewport.
Public method DeleteLayerState Deletes a layer state with the specified name.
Public method ExportLayerState Exports a specific layer state.
Public method GetLayerStateDescription Retrieves the description from a specified layer state.
Public method GetLayerStateLayers Retrieves a list of names of layers associated with a specified layer state.
Public method GetLayerStateMask Retrieves a layer state mask from a specific layer state. A layer state mask determines which layer attributes are stored in the layer state.
Public method GetLayerStateNames Retrieves a list of names of layer states contained in the current database.
Public method HasLayerState Indicates if the layer state with the given name is managed by this layer state manager object.
Public method ImportLayerState Imports a layer state.
Public method ImportLayerStateFromDb Imports a specific layer state from the database.
Public method LayerStateHasViewportData Checks whether the specified layer has viewport data.
Public method LayerStatesDictionaryId Gets the layer state dictionary ID if present in the current database. The layer state dictionary can be created if it is not present and the bCreateIfNotPresent parameter is set to true.
Public method RenameLayerState Renames a layer state.
Public method RestoreLayerState Restores the specified layer state.
Public method SaveLayerState Saves a layer state to the current database.
Public method SetLayerStateDescription Sets a description for a specified layer state.
Public method SetLayerStateMask Sets the layer state mask for a specific layer state.
Top
Events
Fields
  Name Description
Public field m_pAbortLayerStateDelete Event triggered when the layer state delete process is aborted.
Public field m_pAbortLayerStateRename Event triggered when the layer state rename process is aborted.
Public field m_pAbortLayerStateRestore Event triggered when the layer state restore process is aborted.
Public field m_pLayerStateCompareFailed Event triggered when the layer state comparison failed.
Public field m_pLayerStateCreated Event triggered when the layer state is created.
Public field m_pLayerStateDeleted Event triggered when the layer state is deleted.
Public field m_pLayerStateRenamed Event triggered when the layer state is renamed.
Public field m_pLayerStateRestored Event triggered when the layer state is restored.
Public field m_pLayerStateToBeDeleted Event triggered when the layer state is about to be deleted.
Public field m_pLayerStateToBeRenamed Event triggered when the layer state is about to be renamed.
Public field m_pLayerStateToBeRestored Event triggered when the layer state is about to be restored.
Top
See Also

©  Bricsys NV. All rights reserved.