NurbCurve3d(Point3dCollection,
Tolerance) Constructor
|
Constructor for the NurbCurve3d class.
Constructs a 3D curve interpolating a given array of 3D points
within a given tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public NurbCurve3d(
Point3dCollection fitPoints,
Tolerance fitTolerance
)
Public Sub New (
fitPoints As Point3dCollection,
fitTolerance As Tolerance
)
public:
NurbCurve3d(
Point3dCollection^ fitPoints,
Tolerance fitTolerance
)
new :
fitPoints : Point3dCollection *
fitTolerance : Tolerance -> NurbCurve3d
Parameters
- fitPoints Point3dCollection
- [in] Array of 3D points through which to fit the curve.
- fitTolerance Tolerance
- [in] Maximum deviation of the curve from the fit points.
See Also