AssocDependencySetDependentOnObject
Method
|
Sets the dependent-on-object of this
dependency to be the specified compoundId
parameter.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public void SetDependentOnObject(
CompoundObjectId compoundId
)
Public Sub SetDependentOnObject (
compoundId As CompoundObjectId
)
public:
void SetDependentOnObject(
CompoundObjectId^ compoundId
)
member SetDependentOnObject :
compoundId : CompoundObjectId -> unit
Parameters
- compoundId CompoundObjectId
- [out] Database object on which this dependency should be
dependent.
Remarks
Unlike the
AttachToObject() method, this method does not add this dependency
to the list of persistent reactors of the object. It is recommended
to use the AttachToObject() method. Client code shouldn't call this
method.
See Also