CompoundObjectId Class

This class is used to identify an object in a database when the object is referenced via a path of BlockReferences. The object may reside in the host database, in an external reference database, or even in another unrelated database.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesCompoundObjectId

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class CompoundObjectId : RXObject

The CompoundObjectId type exposes the following members.

Constructors
  Name Description
Public method CompoundObjectId Default constructor for the CompoundObjectId class.
Public method CompoundObjectId(CompoundObjectId) Copy constructor for the CompoundObjectId class. Copies the passed compound object ID.
Public method CompoundObjectId(ObjectId) Constructor for the CompoundObjectId class. Creates a compound object ID from the passed object ID.
Public method CompoundObjectId(ObjectId, Database) Constructor for the CompoundObjectId class. Creates a compound object ID from the passed object ID in a given host database.
Public method CompoundObjectId(ObjectId, ObjectIdCollection, Database) Constructor for the CompoundObjectId class. Creates a compound object ID from the passed object ID and a path of BlockReferences.
Top
Properties
  Name Description
Public property FullPath  
Public property IsEmpty  
Public property IsExternal  
Public property IsSimpleObjectId  
Public property LeafId  
Public property Path  
Public property TopId  
Public property Transform  
Top
Methods
  Name Description
Public method DwgInFields Reads the .dwg file data of this object.
Public method DwgOutFields Writes the .dwg file data of this object.
Public method DxfInFields Reads the .dxf file data of this object.
Public method DxfOutFields Writes the .dxf file data of this object.
Public method Equals Checks objects for equality.
(Overrides DisposableWrapperEquals(Object))
Public method IsValid Checks whether this compound object ID is valid according to the level of testing.
Public methodStatic member NullId Returns a null compound object ID.
Public method Remap Remaps all object identifiers that relate to this compound object ID using the given idMap.
Public method Set(CompoundObjectId, Database) Sets this CompoundObjectId from the passed compound object ID in a given database.
Public method Set(ObjectId, Database) Sets this CompoundObjectId from the passed ObjectId in a given database.
Public method Set(ObjectId, ObjectIdCollection, Database) Sets this CompoundObjectId from the passed object ID and a path of BlockReferences.
Public method SetEmpty Sets this CompoundObjectId to be an empty compound object ID that has no data.
Public method SetFullPath Sets this CompoundObjectId from the object that stores the path of block references.
Top
Operators
  Name Description
Public operator Assign(CompoundObjectId) Assignment operator for the CompoundObjectId object.
Public operator Assign(ObjectId) Assignment operator for the CompoundObjectId object.
Public operator Equality(CompoundObjectId) Equality operator for the CompoundObjectId object. Checks whether the passed object is equal to this object.
Public operator Inequality(CompoundObjectId) Inequality operator for the CompoundObjectId object. Checks whether the passed object is not equal to this object.
Top
See Also

©  Bricsys NV. All rights reserved.