RegionCreateFromCurves Method
|
Creates region entities from the closed loops
defined by the specified curve segments.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static DBObjectCollection CreateFromCurves(
DBObjectCollection curveSegments
)
Public Shared Function CreateFromCurves (
curveSegments As DBObjectCollection
) As DBObjectCollection
public:
static DBObjectCollection^ CreateFromCurves(
DBObjectCollection^ curveSegments
)
static member CreateFromCurves :
curveSegments : DBObjectCollection -> DBObjectCollection
Parameters
- curveSegments DBObjectCollection
- [in] Array of curve segments. Each curve segment must be one of
the following: 3dPolyline, Arc, Circle, Ellipse, Line, Polyline or
Spline.
Return Value
DBObjectCollection
A collection of created regions.
Remarks
The newly created
regions are non-database residents. It is up to the caller to
either add them to a database or to delete them.
See Also