DBObjectCollection Class

This class represents a collection of database objects.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesDBObjectCollection

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class DBObjectCollection : DisposableWrapper, 
        IList

The DBObjectCollection type exposes the following members.

Constructors
  Name Description
Public method DBObjectCollection Default constructor for the DBObjectCollection class. Creates an empty collection.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property Item Property that represents an item from the collection at the specified index.
Top
Methods
  Name Description
Public method Add Adds a database object to the collection.
Public method Clear Clears this collection of database objects.
Public method Contains Checks whether this collection contains a database object that matches the specified object.
Public method CopyTo  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method GetEnumerator Returns the enumerator for this database object collection.
Public method IndexOf Returns the index of the database object in the collection that matches the specified database object.
Public method Insert Inserts the specified database object to the collection at the provided index.
Public method Remove Removes the database object that matches the specified database object from the collection.
Public method RemoveAt Removes the database object from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.