FieldEvaluatorFormat Method
|
Returns the evaluated field value as a
string.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract string Format(
Field pField
)
Public MustOverride Function Format (
pField As Field
) As String
public:
virtual String^ Format(
Field^ pField
) abstract
abstract Format :
pField : Field -> string
Parameters
- pField Field
- [in] Field value to be formatted.
Return Value
String
Remarks
This function is
called by the field framework when a field is queried to get the
evaluated field value as a string. The evaluator can implement this
method to support custom formatting of field values. If the
evaluator does not implement this method, the standard data types
are formatted using default formats.
See Also