Field Class |
The Field type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Field | Default constructor for the Field class. |
![]() |
Field(String) | Constructor for the Field class. Creates a field with the specified field code. |
![]() |
Field(IntPtr, Boolean) | Initializes a new instance of the Field class |
![]() |
Field(String, Boolean) | Constructor for the Field class. Creates a field with the specified field code. |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
DataType | Property that represents the data type of the field evaluation result. |
![]() |
![]() |
![]() |
EvaluationOption | Property that represents the evaluation options for the field. |
![]() |
EvaluationStatus | Property that represents the evaluation status. |
![]() |
EvaluatorId | Property that represents the ID of the evaluator used for this field. |
![]() |
![]() |
FilingOption | Property that represents the filing option for this field. |
![]() |
Format | Property that represents the output format for this field. |
![]() |
![]() |
![]() |
![]() |
HyperLink | Property that represents a hyperlink associated with this object. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
IsTextField | Property that indicates whether this field is a text field with embedded fields. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
State | Property that represents a field state by one of the FieldState values or their combination. |
![]() |
![]() |
![]() |
Value | Property that represents a field value in its original data type. |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
ConvertToTextField | Converts the field to a text field. Currently not implemented. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Evaluate | Evaluates a text field. |
![]() |
Evaluate(Int32, Database) | Evaluates a text field according to the specified parameters. |
![]() |
![]() |
GetChildren | Retrieves the child field. If this field is a text field, the child fields are embedded in the text. |
![]() |
GetData | Gets data from the field object using a key. |
![]() |
![]() |
![]() |
![]() |
GetFieldCode | Retrieves a field code as a string value. |
![]() |
GetFieldCode(FieldCodeFlags) | Retrieves a field code as a string value. |
![]() |
GetFieldCodeWithChildren | Retrieves a field code in various forms. |
![]() |
GetFieldCodeWithChildren(FieldCodeFlags) | Retrieves a field code in various forms. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
GetStringValue | Retrieves a string value associated with this field. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
SetData(String, Object) | Sets data in the field object with the specified key. |
![]() |
SetData(String, Object, Boolean) | Sets data in the field object with the specified key. |
![]() |
![]() |
![]() |
SetFieldCode | Sets the field code. |
![]() |
SetFieldCodeWithChildren(FieldCodeWithChildren) | Sets a group of nested (child) fields and field code for this and nested fields. |
![]() |
SetFieldCodeWithChildren(FieldCodeFlags, FieldCodeWithChildren) | Sets a group of nested (child) fields and field code for this and nested fields. |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
SwapReferences | This method performs object ID reference translations similar
to those done at the end of deep cloning. References between
objects in the workset have their object identifiers translated to
the swapped object identifiers of the referenced objects. In
contrast to cloning, this translation must occur in both
directions. Accordingly, it is possible to pass two different ID
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
Name | Description | |
---|---|---|
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
![]() |
© Bricsys NV. All rights reserved. |