NurbCurve3dSetFitData(Int32,
Point3dCollection, Tolerance) Method
|
Sets the fit data for this spline.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetFitData(
int degree,
Point3dCollection fitPoints,
Tolerance fitTolerance
)
Public Sub SetFitData (
degree As Integer,
fitPoints As Point3dCollection,
fitTolerance As Tolerance
)
public:
void SetFitData(
int degree,
Point3dCollection^ fitPoints,
Tolerance fitTolerance
)
member SetFitData :
degree : int *
fitPoints : Point3dCollection *
fitTolerance : Tolerance -> unit
Parameters
- degree Int32
- [in] Degree of the curve.
- fitPoints Point3dCollection
- [in] Interpolation points.
- fitTolerance Tolerance
- [in] Geometric tolerance.
Remarks
Recomputes the
spline from the input fit points and makes it of the specified
degree. If fitTolerance is not 0, the constructed spline may not
pass through the fit points. But the maximum distance from any fit
point to the constructed spline is no greater than fitTolerance.
High degree values make the curve more flexible. For example,
degree of 1 is used to define a polyline, and degree of 2 is used
to define a NURBS circle, etc.
See Also