Point3AngularDimension(Point3d,
Point3d, Point3d, Point3d, String,
ObjectId) Constructor
|
Constructor. Creates a Point3AngularDimension
object with specified parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3AngularDimension(
Point3d centerPoint,
Point3d line1Point,
Point3d line2Point,
Point3d arcPoint,
string dimensionText,
ObjectId dimensionStyle
)
Public Sub New (
centerPoint As Point3d,
line1Point As Point3d,
line2Point As Point3d,
arcPoint As Point3d,
dimensionText As String,
dimensionStyle As ObjectId
)
public:
Point3AngularDimension(
Point3d centerPoint,
Point3d line1Point,
Point3d line2Point,
Point3d arcPoint,
String^ dimensionText,
ObjectId dimensionStyle
)
new :
centerPoint : Point3d *
line1Point : Point3d *
line2Point : Point3d *
arcPoint : Point3d *
dimensionText : string *
dimensionStyle : ObjectId -> Point3AngularDimension
Parameters
- centerPoint Point3d
- [in] Vertex point of the angle to be dimensioned.
- line1Point Point3d
- [in] End point of the first definition line which is the start
point for the first extension line.
- line2Point Point3d
- [in] End point of the second definition line which is the start
point for the second extension line.
- arcPoint Point3d
- [in] Point lying on the dimension arc.
- dimensionText String
- [in] Dimension text to replace the measured value text.
- dimensionStyle ObjectId
- [in] ObjectId of the dimension style that is used to draw the
dimension entity.
See Also