MInsertBlock(Point3d, ObjectId, Int16, Int16, Double, Double) Constructor

Constructor for the MInsertBlock class.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public MInsertBlock(
        Point3d position,
        ObjectId blockTableRecord,
        short columns,
        short rows,
        double colSpacing,
        double rowSpacing
)

Parameters

position  Point3d
[in] Position of this MInsertBlock object.
blockTableRecord  ObjectId
[in] Block table record.
columns  Int16
[in] The number of columns of the BlockTableRecord image to display by this object.
rows  Int16
[in] The number of rows of the BlockTableRecord image to display by this object.
colSpacing  Double
[in] Spacing between the columns of the BlockTableRecord image that is displayed by this object.
rowSpacing  Double
[in] Spacing between the rows of the BlockTableRecord image that is displayed by this object.
See Also

©  Bricsys NV. All rights reserved.