TableStyleGridVisibility Method
|
Returns the grid visibility for the specified
gridline type and row type.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual bool GridVisibility(
GridLineType gridLineType,
RowType rowType
)
Public Overridable Function GridVisibility (
gridLineType As GridLineType,
rowType As RowType
) As Boolean
public:
virtual bool GridVisibility(
GridLineType gridLineType,
RowType rowType
)
abstract GridVisibility :
gridLineType : GridLineType *
rowType : RowType -> bool
override GridVisibility :
gridLineType : GridLineType *
rowType : RowType -> bool
Parameters
- gridLineType GridLineType
-
- rowType RowType
-
Return Value
Boolean
Grid visibility value that can be one of the following:
NameValueVisible 0 Invisible 1
Remarks
The gridlineType
parameter must have one of the following values:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal grid line of the table, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top grid lines.
HorizontalBottom 0x04 Bottom or top horizontal grid line of the
table, depending on the flow direction of the table rows (down or
up). VerticalLeft 0x08 The grid line at the left edge of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right grid lines. VerticalRight 0x20 The grid line at the right
edge of the table.
See Also