EllipticalArc3d(Point3d, Vector3d,
Vector3d, Double, Double, Double, Double) Constructor
|
Constructor for the EllipticalArc2d class.
Creates an elliptical arc by the specified parameters.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public EllipticalArc3d(
Point3d center,
Vector3d majorAxis,
Vector3d minorAxis,
double majorRadius,
double minorRadius,
double startAngle,
double endAngle
)
Public Sub New (
center As Point3d,
majorAxis As Vector3d,
minorAxis As Vector3d,
majorRadius As Double,
minorRadius As Double,
startAngle As Double,
endAngle As Double
)
public:
EllipticalArc3d(
Point3d center,
Vector3d majorAxis,
Vector3d minorAxis,
double majorRadius,
double minorRadius,
double startAngle,
double endAngle
)
new :
center : Point3d *
majorAxis : Vector3d *
minorAxis : Vector3d *
majorRadius : float *
minorRadius : float *
startAngle : float *
endAngle : float -> EllipticalArc3d
Parameters
- center Point3d
- [in] The center of this elliptical arc.
- majorAxis Vector3d
- [in] The major axis of this elliptical arc.
- minorAxis Vector3d
- [in] The minor axis of this elliptical arc.
- majorRadius Double
- [in] The major radius of this elliptical arc.
- minorRadius Double
- [in] The minor radius of this elliptical arc.
- startAngle Double
- [in] Start angle of this elliptical arc (angle offset from
which arc segments are drawn).
- endAngle Double
- [in] End angle of this elliptical arc (angle offset to which
arc segments are drawn).
See Also