Solid3dCreateSweptSolid(Entity, Entity,
SweepOptions) Method
|
Creates a swept solid by sweeping a curve,
region, or planar surface along the specified path.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void CreateSweptSolid(
Entity sweepEntity,
Entity pathEntity,
SweepOptions sweepOptions
)
Public Overridable Sub CreateSweptSolid (
sweepEntity As Entity,
pathEntity As Entity,
sweepOptions As SweepOptions
)
public:
virtual void CreateSweptSolid(
Entity^ sweepEntity,
Entity^ pathEntity,
SweepOptions^ sweepOptions
)
abstract CreateSweptSolid :
sweepEntity : Entity *
pathEntity : Entity *
sweepOptions : SweepOptions -> unit
override CreateSweptSolid :
sweepEntity : Entity *
pathEntity : Entity *
sweepOptions : SweepOptions -> unit
Parameters
- sweepEntity Entity
- [in] Entity for sweeping.
- pathEntity Entity
- [in] Curve entity that determines the path to sweep along.
- sweepOptions SweepOptions
- [in] Sweep options.
Remarks
By default the
SweepOptions object has the SweepOptionsAlignOption.NoAlignment
value for alignment. Set the
SweepOptionsAlignOption.kAlignSweepEntityToPath value for the
alignment of the sweep options before calling this method. This
method is implemented only for the Spatial modeler.
See Also