GeometryPolyline(Point3dCollection,
Vector3d, IntPtr) Method
|
Introduces a polyline into the vectorization
context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Polyline(
Point3dCollection points,
Vector3d normal,
IntPtr subEntityMarker
)
Public MustOverride Function Polyline (
points As Point3dCollection,
normal As Vector3d,
subEntityMarker As IntPtr
) As Boolean
public:
virtual bool Polyline(
Point3dCollection^ points,
Vector3d normal,
IntPtr subEntityMarker
) abstract
abstract Polyline :
points : Point3dCollection *
normal : Vector3d *
subEntityMarker : IntPtr -> bool
Parameters
- points Point3dCollection
- [in] Array of vertices for the polyline.
- normal Vector3d
- [in] Normal to the plane on which the polyline lies.
- subEntityMarker IntPtr
- [in] Sub-entity marker of the first segment.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
See Also