GeometryCircularArc(Point3d,
Point3d, Point3d, ArcType) Method
|
Introduces a circular arc to the vectorization
context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool CircularArc(
Point3d start,
Point3d point,
Point3d endingPoint,
ArcType arcType
)
Public MustOverride Function CircularArc (
start As Point3d,
point As Point3d,
endingPoint As Point3d,
arcType As ArcType
) As Boolean
public:
virtual bool CircularArc(
Point3d start,
Point3d point,
Point3d endingPoint,
ArcType arcType
) abstract
abstract CircularArc :
start : Point3d *
point : Point3d *
endingPoint : Point3d *
arcType : ArcType -> bool
Parameters
- start Point3d
- [in] First point of a 3-point arc.
- point Point3d
- [in] Second point of a 3-point arc.
- endingPoint Point3d
- [in] Third point of a 3-point arc.
- arcType ArcType
- [in] Arc type.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
Remarks
arcType must be
one of the following: Name Value Description ArcSimple 0 Unfilled.
ArcSector 1 Filled area bounded by the arc and its center. ArcChord
2 Filled area bounded by the arc and its end points.
See Also