Solid3dChamferEdges Method

Creates chamfers at the edges of the solid.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void ChamferEdges(
        SubentityId[] subentityIds,
        SubentityId baseSubentityId,
        double baseDist,
        double otherDist
)

Parameters

subentityIds  SubentityId
[in] Array of edge object IDs. The chamfer is applied at the specified edges.
baseSubentityId  SubentityId
[in] Base face object IDs. Chamfer is applied on the specified face.
baseDist  Double
[in] Chamfer distance for the base face.
otherDist  Double
[in] Chamfer distance for other faces.
Remarks
This method is implemented only for the Spatial modeler.
See Also

©  Bricsys NV. All rights reserved.