LayerStateManagerRestoreLayerState Method
|
Restores the specified layer state.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void RestoreLayerState(
string name,
ObjectId id,
int undefinedLayerStatePolicy,
LayerStateMasks clientMask
)
Public Sub RestoreLayerState (
name As String,
id As ObjectId,
undefinedLayerStatePolicy As Integer,
clientMask As LayerStateMasks
)
public:
void RestoreLayerState(
String^ name,
ObjectId id,
int undefinedLayerStatePolicy,
LayerStateMasks clientMask
)
member RestoreLayerState :
name : string *
id : ObjectId *
undefinedLayerStatePolicy : int *
clientMask : LayerStateMasks -> unit
Parameters
- name String
- [in] Name of the layer state to be restored.
- id ObjectId
- [in] Object ID of the viewport to restore the layer state
for.
- undefinedLayerStatePolicy Int32
- [in] Restore flags.
- clientMask LayerStateMasks
- [in] Layer state mask of the target viewport.
Remarks
A layer state mask
determines which layer attributes are restored from the layer
state. A layer state mask must be a combination of one or more of
the following: NameValueNone 0x0000 On 0x0001 Frozen 0x0002 Locked
0x0004 Plot 0x0008 NewViewport 0x0010 Color 0x0020 LineType 0x0040
LineWeight 0x0080 PlotStyle 0x0100 CurrentViewport 0x0200
Transparency 0x0400 The undefinedLayerStatePolicy parameter is a set of flags
that determine what to do with layers that are missing from the
layer state being restored but are present in the viewport. The
kRestoreAsOverrides flag determines whether the properties that can
be overriden in a viewport (such as color) are restored as
overrides. The undefinedLayerStatePolicy
flags parameter must be a combination of one or more of the
following flags: NameValuekUndefDoNothing 0x0000 kUndefTurnOff 0x0001
kUndefFreeze 0x0002 kRestoreAsOverrides 0x0004
See Also