DatabaseAttachXref Method
|
Attaches the external reference file specified
by fileName to the database. As a result a new external reference
BlockTableRecord is created. The new block table record's name is
specified in blockName. Its object ID is returned.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public ObjectId AttachXref(
string fileName,
string blockName
)
Public Function AttachXref (
fileName As String,
blockName As String
) As ObjectId
public:
ObjectId AttachXref(
String^ fileName,
String^ blockName
)
member AttachXref :
fileName : string *
blockName : string -> ObjectId
Parameters
- fileName String
- [in] External reference file path name.
- blockName String
- [in] External reference block name to use.
Return Value
ObjectId
Remarks
The document is
not locked during the external reference attachment, and a new
instance of the BlockReference instance class is not created.
See Also