DrawableViewportDraw Method
|
Creates a viewport-dependent geometric
representation of this object.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void ViewportDraw(
ViewportDraw vd
)
Public Sub ViewportDraw (
vd As ViewportDraw
)
public:
void ViewportDraw(
ViewportDraw^ vd
)
member ViewportDraw :
vd : ViewportDraw -> unit
Parameters
- vd ViewportDraw
- [in] Viewport draw interface.
Remarks
This function is
called once per viewport. By overriding this function, it is
possible to have totally different images in each viewport; a
schematic in one viewport, a layout in another. The default
implementation of this function does nothing. This function can be
overridden in custom classes.
See Also