ViewportDraw Class

This class defines the functionality for viewport-dependent entity-level vectorization.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceCommonDraw
          Teigha.GraphicsInterfaceViewportDraw

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class ViewportDraw : CommonDraw

The ViewportDraw type exposes the following members.

Constructors
  Name Description
Protected method ViewportDraw Initializes a new instance of the ViewportDraw class
Top
Properties
  Name Description
Public property Geometry Property that represents the ViewportGeometry object associated with this object.
Public property SequenceNumber Property that represents the number of viewports that have been deleted from the current database during this editing session.
Public property Viewport Property that represents the Viewport object associated with this object.
Public property ViewportObjectId Property that represents the persistent object identifier of the Viewport object associated with this object.
Top
Methods
  Name Description
Public method IsValidId Property that represents the Viewport object associated with this object.
Top
Remarks
Consider a circular cone. A circular cone can be drawn as a circle and two silhouette lines. The circle could be drawn with the subWorldDraw() function, but the silhouette lines are dependent on the view direction and must be computed by subViewportDraw().
See Also

©  Bricsys NV. All rights reserved.