DatabaseApplyPartialOpenFilters
Method
|
Filters the model space entities of a database
to only bring part of the drawing into memory. The filter applied
is the intersection of entities in the view and the entities on the
specified layers. Only entities both within the view and on the
specified layers are brought into memory.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void ApplyPartialOpenFilters(
SpatialFilter spatialFilter,
LayerFilter layerFilter
)
Public Sub ApplyPartialOpenFilters (
spatialFilter As SpatialFilter,
layerFilter As LayerFilter
)
public:
void ApplyPartialOpenFilters(
SpatialFilter^ spatialFilter,
LayerFilter^ layerFilter
)
member ApplyPartialOpenFilters :
spatialFilter : SpatialFilter *
layerFilter : LayerFilter -> unit
Parameters
- spatialFilter SpatialFilter
- [in] Specifies the model space volume to be used for spatial
filtering.
- layerFilter LayerFilter
- [in] Specifies the layers to be used for filtering.
Remarks
Currently not
implemented.
See Also