Curve2dGetSamplePoints(Double, Double, Double) Method

Retrieves specified arrays of sample points along this curve and their parameter values.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public PointOnCurve2d[] GetSamplePoints(
        double fromParameter,
        double toParameter,
        double approxEps
)

Parameters

fromParameter  Double
[in] First parameter value that represents the start of the interval.
toParameter  Double
[in] Second parameter value that represents the end of the interval.
approxEps  Double
[in] Approximation spacing (step) along a parametric range.

Return Value

PointOnCurve2d
Array of sample points.
See Also

©  Bricsys NV. All rights reserved.