PointOnCurve2d Class

This class represents points along 2D curves. The point representation includes its parameter value, its coordinates, and the derivatives of the curve at that point. For more information, see Working with Evaluator Classes.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryPointEntity2d
          Teigha.GeometryPointOnCurve2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class PointOnCurve2d : PointEntity2d

The PointOnCurve2d type exposes the following members.

Constructors
  Name Description
Public method PointOnCurve2d Default constructor for the PointOnCurve2d class. Creates a default corresponding C++ object with a point that does not lie on any curve and has a parameter value of 0.
Public method PointOnCurve2d(Curve2d) Constructor for the PointOnCurve2d class. Creates a point on the specified curve. Parameter value for the point on the curve is 0.
Public method PointOnCurve2d(Curve2d, Double) Constructor for the PointOnCurve2d class. Creates a point on the specified curve with a provided parameter value.
Top
Properties
  Name Description
Public property Curve  
Public property Parameter  
Public property Point  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetDerivative(Int32) Returns the derivative of the curve at the point on the curve.
Public method GetDerivative(Int32, Double) Returns the derivative of the curve at the point on the curve.
Public method GetDerivative(Int32, Curve2d, Double) Returns the derivative of the curve at the point on the curve.
Public method GetPointAtParameter Resets the parameter on a curve and returns a point that corresponds to that parameter.
Public method GetPointOnCurve Sets the parameter on the specified curve and returns a point that corresponds to that parameter.
Top
See Also

©  Bricsys NV. All rights reserved.