FileDependencyInfoToString(IFormatProvider)
Method
|
Returns an equivalent string representation of
this object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public string ToString(
IFormatProvider provider
)
Public Function ToString (
provider As IFormatProvider
) As String
public:
String^ ToString(
IFormatProvider^ provider
)
member ToString :
provider : IFormatProvider -> string
Parameters
- provider IFormatProvider
- [in] Provides a mechanism for retrieving an object to control
formatting.
Return Value
String
Returns the string that stores information about file dependency in
the following order (separated by commas):
* Full name of file. * Base name of
file. * Path at which file was found. * Fingerprint GUID. * Version
GUID. * Name of the application or feature that created this entry.
* Flag indicating whether the database was modified since the last
save. * Flag indicating whether the entry affects the screen view.
* Unique File Dependency List index. * Time stamp (seconds since
1/1/1980). * Current file size. * Current reference count for
database.
See Also