FileDependencyInfo Structure

This class represents entries in the .dwg section of the File Dependency List.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesFileDependencyInfo

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct FileDependencyInfo

The FileDependencyInfo type exposes the following members.

Properties
  Name Description
Public property Feature Property that represents the name of the application or feature that created this entry.
Public property FileName Property that represents the base name of the file.
Public property FileSize Property that represents the current file size.
Public property FingerprintGuid Property that represents the fingerprint GUID.
Public property FoundPath Property that represents the path at which the file was found.
Public property FullFileName Property that represents the full name of the file.
Public property Index Property that represents a unique file dependency list index.
Public property IsAffectsGraphics Property that indicates whether this entry affects the screen view.
Public property IsModified Property that indicates whether the database was modified since the last save.
Public property ReferenceCount Property that represents the current reference count for a database.
Public property TimeStamp Property that represents the time stamp (seconds since 1/1/1980).
Public property VersionGuid Property that represents the version GUID.
Top
Methods
  Name Description
Public method ToString Returns an equivalent string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
See Also

©  Bricsys NV. All rights reserved.