AssocArrayRectangularParameters(Double,
Double, Double, Int32, Int32, Int32, Double,
Double) Constructor
|
Constructor for the AssocArrayPolarParameters
class. Creates an object with the specified spacing, count and
angle parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public AssocArrayRectangularParameters(
double columnSpacing,
double rowSpacing,
double levelSpacing,
int columnCount,
int rowCount,
int levelCount,
double rowElevation,
double axesAngle
)
Public Sub New (
columnSpacing As Double,
rowSpacing As Double,
levelSpacing As Double,
columnCount As Integer,
rowCount As Integer,
levelCount As Integer,
rowElevation As Double,
axesAngle As Double
)
public:
AssocArrayRectangularParameters(
double columnSpacing,
double rowSpacing,
double levelSpacing,
int columnCount,
int rowCount,
int levelCount,
double rowElevation,
double axesAngle
)
new :
columnSpacing : float *
rowSpacing : float *
levelSpacing : float *
columnCount : int *
rowCount : int *
levelCount : int *
rowElevation : float *
axesAngle : float -> AssocArrayRectangularParameters
Parameters
- columnSpacing Double
- [in] Column spacing to set.
- rowSpacing Double
- [in] Row spacing to set.
- levelSpacing Double
- [in] Level spacing to set.
- columnCount Int32
- [in] Column count of the array.
- rowCount Int32
- [in] Row count of the array.
- levelCount Int32
- [in] Level count of the array.
- rowElevation Double
-
- axesAngle Double
- [in] Angle between the first row and first column of the
array.
See Also