AssocArrayRectangularParameters Class

This .NET class wraps the OdDbAssocArrayRectangularParameters class.

It provides an interface for managing polar array parameters.

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesAssocArrayParameters
          Teigha.DatabaseServicesAssocArrayCommonParameters
            Teigha.DatabaseServicesAssocArrayRectangularParameters

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class AssocArrayRectangularParameters : AssocArrayCommonParameters

The AssocArrayRectangularParameters type exposes the following members.

Constructors
  Name Description
Public method AssocArrayRectangularParameters Default constructor for the AssocArrayRectangularParameters class. Creates an object that wraps the corresponding C++ OdDbAssocArrayRectangularParameters object with default parameters.
Public method AssocArrayRectangularParameters(Double, Double, Double, Int32, Int32, Int32, Double, Double) Constructor for the AssocArrayPolarParameters class. Creates an object with the specified spacing, count and angle parameters.
Top
Properties
  Name Description
Public property AxesAngle  
Public property ColumnCount  
Public property ColumnSpacing  
Public property XAxisDirection  
Public property YAxisDirection  
Top
Methods
  Name Description
Public method GetAxesAngle Retrieves the angle between the first row and first column of the rectangular array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetColumnCount Retrieves the column count of the rectangular array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method GetColumnSpacing Retrieves the column spacing of the rectangular array. If there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method executes.
Public method SetAxesAngle Sets the angle between the first column and first row in the polar array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetColumnCount Sets the column count of the rectangular array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Public method SetColumnSpacing Sets the column spacing of the rectangular array. If there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
Top
See Also

©  Bricsys NV. All rights reserved.