SecurityParametersInequality
Operator
|
Inequality operator for the SecurityParameters
class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static bool operator !=(
SecurityParameters a,
SecurityParameters b
)
Public Shared Operator <> (
a As SecurityParameters,
b As SecurityParameters
) As Boolean
public:
static bool operator !=(
SecurityParameters^ a,
SecurityParameters^ b
)
static let inline (<>)
a : SecurityParameters *
b : SecurityParameters : bool
Parameters
- a SecurityParameters
- [in] Left SecurityParameters object to compare.
- b SecurityParameters
- [in] Right SecurityParameters object to compare.
Return Value
Boolean
True if both instances are not equal (both can be nullptr) or at
least one of the following conditions fails: * Passwords are equal.
* Provider names are equal. * Names of the certificate (digital ID)
subjects are equal. * Names of the certificate (digital ID) issuers
are equal. * Serial numbers of certificates are equal. * Comments
provided with the signatures are equal. * Names of the time servers
are equal. * Actions to perform are equal. * Security algorithms
are equal. * Lengths of the encryption keys are equal. * Encryption
provider types are equal.
See Also