TransientManagerAddTransient
Method
|
Appends a child drawable to a parent drawable
in the transient drawables manager.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool AddTransient(
Drawable added,
TransientDrawingMode mode,
int subDrawingMode,
IntegerCollection viewportNumbers
)
Public Function AddTransient (
added As Drawable,
mode As TransientDrawingMode,
subDrawingMode As Integer,
viewportNumbers As IntegerCollection
) As Boolean
public:
bool AddTransient(
Drawable^ added,
TransientDrawingMode mode,
int subDrawingMode,
IntegerCollection^ viewportNumbers
)
member AddTransient :
added : Drawable *
mode : TransientDrawingMode *
subDrawingMode : int *
viewportNumbers : IntegerCollection -> bool
Parameters
- added Drawable
- [in] Transient drawable to add.
- mode TransientDrawingMode
- [in] Transient drawable mode.
- subDrawingMode Int32
- [in] Draw order index.
- viewportNumbers IntegerCollection
- [in] Collection of viewport indices.
Return Value
Boolean
true if the drawable is successfully
added or false in one of the following cases: * The passed mode is
greater than or equal to the TransientDrawingMode.Count. * The
specified draw order index exceeds the maximum value of the signed
integer.
See Also