PlanarEntityClosestPointToPlanarEntity(PlanarEntity)
Method
|
Calculates the point on this planar entity
that is closest to the specified planar entity and the point on the
specified planar entity that is closest to this planar
entity.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] ClosestPointToPlanarEntity(
PlanarEntity otherPlane
)
Public Function ClosestPointToPlanarEntity (
otherPlane As PlanarEntity
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlanarEntity(
PlanarEntity^ otherPlane
)
member ClosestPointToPlanarEntity :
otherPlane : PlanarEntity -> Point3d[]
Parameters
- otherPlane PlanarEntity
- [in] A plane to which a closest point is calculated.
Return Value
Point3d
Array with two points. The first point is the closest point on the
specified plane, and the second point is the closest point on this
planar entity.
See Also