IFCImportReactorOnIfcProduct(IfcEntity,
Boolean, IfcEntity) Method
|
Note: This API is now obsolete.
Namespace: Bricscad.Ifc
Assembly: BrxMgd (in BrxMgd.dll) Version:
24.0.1.0
Syntax
[ObsoleteAttribute("OnIfcProduct(IfcEntity, Boolean, IfcEntity) is deprecated, please use OnStart with new signature.")]
public virtual bool OnIfcProduct(
IfcEntity product,
bool isParent,
IfcEntity parentProduct
)
<ObsoleteAttribute("OnIfcProduct(IfcEntity, Boolean, IfcEntity) is deprecated, please use OnStart with new signature.")>
Public Overridable Function OnIfcProduct (
product As IfcEntity,
isParent As Boolean,
parentProduct As IfcEntity
) As Boolean
public:
[ObsoleteAttribute(L"OnIfcProduct(IfcEntity, Boolean, IfcEntity) is deprecated, please use OnStart with new signature.")]
virtual bool OnIfcProduct(
IfcEntity^ product,
bool isParent,
IfcEntity^ parentProduct
)
[<ObsoleteAttribute("OnIfcProduct(IfcEntity, Boolean, IfcEntity) is deprecated, please use OnStart with new signature.")>]
abstract OnIfcProduct :
product : IfcEntity *
isParent : bool *
parentProduct : IfcEntity -> bool
[<ObsoleteAttribute("OnIfcProduct(IfcEntity, Boolean, IfcEntity) is deprecated, please use OnStart with new signature.")>]
override OnIfcProduct :
product : IfcEntity *
isParent : bool *
parentProduct : IfcEntity -> bool
Parameters
- product IfcEntity
-
- isParent Boolean
-
- parentProduct IfcEntity
-
Return Value
Boolean
See Also