IFCImport
|
The IFCImportReactor type exposes the following members.
Name | Description | |
---|---|---|
![]() |
IFCImportReactor | Initializes a new instance of the IFCImportReactor class |
Name | Description | |
---|---|---|
![]() |
AngleConversionFactor | Obsolete. |
![]() |
AreaConversionFactor | Obsolete. |
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
CurrentContext | |
![]() |
Ifc2x3Enabled | |
![]() |
Ifc4Enabled | |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
LengthConversionFactor | Obsolete. |
![]() |
Precision | Obsolete. |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
![]() |
VolumeConversionFactor | Obsolete. |
Name | Description | |
---|---|---|
![]() |
AttachReactor | |
![]() |
BeforeCompletion(Boolean) | Obsolete. |
![]() |
BeforeCompletion(ImportContext, Boolean) | |
![]() |
CreateDefaultRepresentation | Obsolete. |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
CreatePoint | Obsolete. |
![]() |
CreateRepresentationFromItem | Obsolete. |
![]() |
CreateSweptArea | Obsolete. |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject) |
![]() |
DetachReactor | |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetDatabase | Obsolete. |
![]() |
GetEntity(Entity, IfcEntity) | Obsolete. |
![]() |
GetEntity(ObjectId, IfcEntity) | Obsolete. |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetIfcModel | Obsolete. |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetLocalPlacement | Obsolete. |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() ![]() |
IsFullySupported | |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
OnIfcProduct(IfcEntity, Boolean, IfcEntity) | Obsolete. |
![]() |
OnIfcProduct(ImportContext, IfcEntity, Boolean, IfcEntity) | |
![]() |
OnStart(IfcEntity) | Obsolete. |
![]() |
OnStart(ImportContext, IfcEntity, ImportInfo) | |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
© Bricsys NV. All rights reserved. |