Polyline2d(Poly2dType,
Point3dCollection, Double, Boolean, Double, Double,
DoubleCollection) Constructor
|
Constructor for the Polyline2d class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Polyline2d(
Poly2dType type,
Point3dCollection vertices,
double elevation,
bool closed,
double startWidth,
double endWidth,
DoubleCollection bulges
)
Public Sub New (
type As Poly2dType,
vertices As Point3dCollection,
elevation As Double,
closed As Boolean,
startWidth As Double,
endWidth As Double,
bulges As DoubleCollection
)
public:
Polyline2d(
Poly2dType type,
Point3dCollection^ vertices,
double elevation,
bool closed,
double startWidth,
double endWidth,
DoubleCollection^ bulges
)
new :
type : Poly2dType *
vertices : Point3dCollection *
elevation : float *
closed : bool *
startWidth : float *
endWidth : float *
bulges : DoubleCollection -> Polyline2d
Parameters
- type Poly2dType
- [in] Type of the polyline entity.
- vertices Point3dCollection
- [in] Collection of vertices.
- elevation Double
- [in] Elevation of this entity in the OCS.
- closed Boolean
- [in] Flag that specifies whether to make this polyline
closed.
- startWidth Double
- [in] Start width of the polyline. Reserved for future use.
- endWidth Double
- [in] End width of the polyline. Reserved for future use.
- bulges DoubleCollection
- [in] A collection of bulges for vertices.
See Also