TableSetGridVisibility(Boolean,
Int32, Int32) Method
|
Sets the grid visibility for the specified
gridline type and row type in this table entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetGridVisibility(
bool visible,
int borders,
int rows
)
Public Overridable Sub SetGridVisibility (
visible As Boolean,
borders As Integer,
rows As Integer
)
public:
virtual void SetGridVisibility(
bool visible,
int borders,
int rows
)
abstract SetGridVisibility :
visible : bool *
borders : int *
rows : int -> unit
override SetGridVisibility :
visible : bool *
borders : int *
rows : int -> unit
Parameters
- visible Boolean
- [in] Visibility status.
- borders Int32
- [in] Gridline types.
- rows Int32
- [in] Row types.
Remarks
The borders
parameter can be a combination of one or more of the following:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal table's grid line, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top lines.
HorizontalBottom 0x04 Bottom or top horizontal table's grid line,
depending on the flow direction of the table rows (down or up).
VerticalLeft 0x08 The grid line at the left of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right lines. VerticalRight 0x20 The grid line at the right of the
table.
See Also