Table Class

This class represents a table entity in a database. Table is a planar entity that can be created and placed in an arbitrary plane in 3D space. This entity is a rectangular array that stores annotation objects, primarily text.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceDrawable
          Teigha.DatabaseServicesDBObject
            Teigha.DatabaseServicesEntity
              Teigha.DatabaseServicesBlockReference
                Teigha.DatabaseServicesTable

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class Table : BlockReference

The Table type exposes the following members.

Constructors
  Name Description
Public method Table Default constructor for the Table class.
Protected method Table(IntPtr, Boolean) Initializes a new instance of the Table class
Top
Properties
  Name Description
Public property BreakEnabled Property that indicates whether table breaking is enabled.
Public property BreakFlowDirection Property that represents the table break flow direction of this table entity.
Public property BreakOptions Property that represents the the table break option of this table entity.
Public property Cells Property that represents the cells of this table entity.
Public property Columns Property that represents the columns of this table entity.
Public property Direction Property that represents the the unit X-axis for this table entity in WCS coordinates.
Public property FlowDirection Property that represents the the direction that this table entity flows from its first row to the last row.
Public property HasSubSelection Property that indicates whether the table has a sub-selection set of cells.
Public property Height Property that represents the overall height of this table entity.
Public property HorizontalCellMargin Property that represents the horizontal cell margin for this table entity.
Public property IsHeaderSuppressed Obsolete.
Property that indicates whether the header row is suppressed for this table entity. This property is obsolete, use Cell functionality instead.
Public property IsTitleSuppressed Obsolete.
Property that indicates whether the title row is suppressed for this table entity. This property is obsolete, use Cell functionality instead.
Public property MinimumTableHeight Property that represents the minimum overall height for this table entity.
Public property MinimumTableWidth Property that represents the minimum overall width for this table entity.
Public property NumColumns Obsolete.
Property that represents the number of columns in this table entity. This property is obsolete, use Table.Columns.Count instead.
Public property NumRows Obsolete.
Property that represents the number of rows for this table entity. This property is obsolete, use Table.Rows.Count instead.
Public property Rows Property that represents the rows of this table entity.
Public property SubSelection Property that represents the cell range in the sub-selection set.
Public property TableStyle Property that represents the Object ID of the table style used by this table entity.
Public property TableStyleName Property that represents the name of the table style associated with this table.
Public property VerticalCellMargin Property that represents the vertical cell margin for this table entity.
Public property Width Property that represents the overall width for this table entity.
Top
Methods
  Name Description
Public method Alignment(RowType) Returns the cell alignment for the specified row type in this table entity.
Public method Alignment(Int32, Int32) Returns the cell alignment for the specified cell in this table entity.
Public method AttachmentPoint Returns the attachment point of the specified cell in this table entity.
Public method BackgroundColor(RowType) Returns the background color for the specified row type in this table entity.
Public method BackgroundColor(Int32, Int32) Returns the background color for the specified cell in this table entity.
Public method BlockRotation Returns the rotation angle of the block reference in the specified cell in this table entity.
Public method BlockScale Returns the scale factor of the block reference in the specified cell in this table entity.
Public method BlockTableRecordId Returns the Object ID of the block table record in the specified cell in this table entity.
Public method CanDeleteColumns Checks whether columns can be deleted at the specified index.
Public method CanDeleteRows Checks whether rows can be deleted at the specified index.
Public method CanInsertColumn Checks whether new columns can be inserted at the specified index.
Public method CanInsertRow Checks whether new rows can be inserted at the specified index.
Public method CellStyleOverrides Returns the cell style overrides for the specified cell in this table entity.
Public method CellType Returns the cell type of the specified cell in this table entity.
Public method ClearSubSelection Clears the sub-selection set of cells from this table.
Public method ClearTableStyleOverrides Clears the table style overrides for this table entity and/or its cells.
Public method ColumnWidth Returns the width of the specified column in this table entity.
Public method ContentColor(RowType) Returns the content color for the specified row type in this table entity.
Public method ContentColor(Int32, Int32) Returns the content color for the specified cell in this table entity.
Public method CopyFrom(LinkedTableData, TableCopyOptions) Copies the content and format from the source linked table data object.
Public method CopyFrom(LinkedTableData, TableCopyOptions, CellRange, CellRange) Copies the content and format from the source linked table data object.
Public method CopyFrom(Table, TableCopyOptions, CellRange, CellRange) Copies the content and format from the source table.
Public method CreateContent Creates additional content for the cell.
Public method DataType(RowType) Returns the data type of the specified row type.
Public method DataType(Int32, Int32) Returns the data type of the specified cell.
Public method DeleteCellContent Deletes the content of the specified cell in this table entity.
Public method DeleteColumns Deletes the specified number of columns from this table entity.
Public method DeleteContent(CellRange) Deletes content from the cells.
Public method DeleteContent(Int32, Int32) Deletes content from the specified cell.
Public method DeleteContent(Int32, Int32, Int32) Deletes content at the specified index from the specified cell.
Public method DeleteRows Deletes content at the specified index from the specified cell.
Public method FieldId Returns the Object ID of the field in the specified cell in this table entity.
Public method Fill Fills or clears cells in rows or columns by copying or generating series.
Public method Format(RowType) Returns the cell format type.
Public method Format(Int32, Int32) Returns the cell format type.
Public method GenerateLayout Updates this table entity according to its current table style.
Public method GetBlockAttributeValue(Int32, Int32, ObjectId) Gets the attribute value from the block cell using the specified object ID key in this table entity.
Public method GetBlockAttributeValue(Int32, Int32, Int32, ObjectId) Gets the attribute value from the block cell using the specified object ID key in this table entity.
Public method GetBlockTableRecordId Returns the Object Id of the block table record for the content at the specified content index.
Public method GetBreakHeight Returns the table break height of the specified table entity when table breaking is enabled.
Public method GetBreakOffset Returns the table break offset of the specified table entity when table breaking is enabled.
Public method GetBreakSpacing Returns the break spacing for this table entity.
Public method GetCellExtents Returns the cell extents for the specified cell in this table entity.
Public method GetCellState Returns the cell state.
Public method GetCellStyle Returns the cell style. Use a valid row index and pass the column index '-1' to get the style for the row. Use a valid column index and pass the row index '-1' to get the style for the column.
Public method GetColumnName Returns the column name.
Public method GetContentColor Returns the color of the cell content.
Public method GetContentLayout Returns the content layout of the cell.
Public method GetContentTypes(Int32, Int32) Returns the content type of the cell.
Public method GetContentTypes(Int32, Int32, Int32) Returns the content type of the cell.
Public method GetCustomData(Int32, Int32) Returns the custom data value of the cell, column or row. Use a valid row index and pass the column index '-1' to get custom data for the row. Use a valid column index and pass the row index '-1' to get custom data for the column.
Public method GetCustomData(Int32, Int32, String) Returns the custom data value of the cell, column or row as key-value pair. Use a valid row index and pass the column index '-1' to get custom data for the row. Use a valid column index and pass the row index '-1' to get custom data for the column.
Public method GetDataFormat(Int32, Int32) Returns the data format of the cell.
Public method GetDataFormat(Int32, Int32, Int32) Returns the data format of the cell at the specified content index.
Public method GetDataLink Returns the data link if the cell is linked to a data source using data link.
Public method GetDataLink(CellRange) Returns the data link for the specified cell range.
Public method GetDataLink(Int32, Int32) Returns the data links for the specified cell range.
Public method GetDataLinkRange Returns the data link cell range that includes the specified row and column.
Public method GetDataType Returns the data type parameter of the cell.
Public method GetFieldId Returns the field ID at the specified content index of the cell.
Public method GetFormula Returns the formula at the specified content index of the cell.
Public method GetGridColor Returns the grid color of the cell, row or column. Use a valid row index and pass the column index '-1' to get the row grid line color. Use a valid column index and pass the row index '-1' to get the column grid line color.
Public method GetGridDoubleLineSpacing Returns the grid double line spacing of the cell, row or column. Use a valid row index and pass the column index '-1' to get the row grid double line spacing. Use a valid column index and pass the row index '-1' to get the column grid double line spacing.
Public method GetGridLineStyle Returns the grid linestyle of a cell, row or column. Use a valid row index and pass the column index '-1' to get the row grid line style. Use a valid column index and pass the row index '-1' to get the column grid line style.
Public method GetGridLinetype Returns the grid linetype of the cell, row or column. Use a valid row index and pass the column index '-1' to get the row grid linetype. Use a valid column index and pass the row index '-1' to get the column grid linetype.
Public method GetGridLineWeight Returns the grid lineweight of a cell, row or column. Use a valid row index and pass the column index '-1' to get the row grid lineweight. Use a valid column index and pass the row index '-1' to get the column grid lineweight.
Public method GetGridProperty Returns the grid line property parameter of the cell, row or column. Use a valid row index and pass the column index '-1' to get the row grid line property parameter. Use a valid column index and pass the row index '-1' to get the column grid line property parameter.
Public method GetGridVisibility Returns the grid visibility of the cell, row or column. Use a valid row index and pass the column index '-1' to get the row grid visibility. Use a valid column index and pass the row index '-1' to get the column grid visibility.
Public method GetIsAutoScale Checks whether data in the cell is auto-scaled or not.
Public method GetMargin Returns the margin of the cell, row or column as a double value. Use a valid row index and pass the column index '-1' to get the margin for the row. Use a valid column index and pass the row index '-1' to get the margin for the column.
Public method GetMergeAllEnabled Checks whether the merge-all flag is enabled for the cell, row or column.
Public method GetMergeRange Returns merge range of the cell. Returns invalid merge range if the cell is not part of the merge range.
Public method GetNumberOfContents Returns the number of contents in a cell.
Public method GetOverrides(Int32, Int32, Int32) Returns the override in the grid line of the cell, row or column. Use a valid row index and pass the column index '-1' to get the row property override. Use a valid column index and pass the row index '-1' to get the column property override.
Public method GetOverrides(Int32, Int32, GridLineType) Returns the override in the grid line of the cell, row or column. Use a valid row index and pass the column index '-1' to get the row property override. Use a valid column index and pass the row index '-1' to get the column property override.
Public method GetRotation Returns the content rotation angle in radians.
Public method GetScale Returns the scale value of the cell.
Public method GetTextHeight Returns the text height of the cell.
Public method GetTextString(Int32, Int32, Int32) Returns the text string of the cell.
Public method GetTextString(Int32, Int32, Int32, FormatOption) Returns the text string of the cell.
Public method GetTextStyleId Returns the text style of the cell.
Public method GetToolTip Returns the tooltip of the cell.
Public method GetValue(Int32, Int32, Int32) Returns the value of the cell at the specified content index of the cell.
Public method GetValue(Int32, Int32, Int32, FormatOption) Returns the value of the cell at the specified content index of the cell.
Public method GridColor(GridLineType, RowType) Returns the grid color for the specified gridline type and row type in this table entity.
Public method GridColor(Int32, Int32, CellEdgeMasks) Returns the grid color for the specified cell and edge in this table entity.
Public method GridLineWeight(GridLineType, RowType) Returns the grid lineweight for the specified gridline type and row type in this table entity.
Public method GridLineWeight(Int32, Int32, CellEdgeMasks) Returns the grid lineweight for the specified cell and edge in this table entity.
Public method GridVisibility(GridLineType, RowType) Returns the grid visibility for the specified gridline type and row type in this table entity.
Public method GridVisibility(Int32, Int32, CellEdgeMasks) Returns the grid visibility for the specified cell and edge in this table entity.
Public method HasFormula Checks whether the cell has a formula.
Public method HitTest Performs a hit test for the specified point and viewing direction in this table entity. Returns the row index and the column index of the cell, hit by the ray in the output arguments.
Public method InsertColumns Inserts the specified number of columns into this table entity at the specified column index.
Public method InsertColumnsAndInherit Inserts columns at the specified index and inherits their format from the reference column.
Public method InsertRows Inserts the specified number of rows into this table entity at the specified row index.
Public method InsertRowsAndInherit Inserts rows at the specified index and inherits their format from the reference row.
Public method IsAutoScale Checks whether the block in the specified cell in this table entity is automatically scaled and positioned to fit into the cell.
Public method IsBackgroundColorNone(RowType) Checks whether the background color for the specified row type is disabled for this table entity.
Public method IsBackgroundColorNone(Int32, Int32) Checks whether the background color for the specified cell is disabled for this table entity.
Public method IsContentEditable Returns the "editing content flag" cell property.
Public method IsEmpty Returns the "empty flag" cell property.
Public method IsFormatEditable Returns the "editing format flag" cell property.
Public method IsLinked Checks whether a cell is linked to a data source.
Public method IsMergedCell  
Public method MergeCells Merges a rectangular region of cells in this table entity.
Public method MinimumColumnWidth Returns the minimum column width for the specified column in this table entity.
Public method MinimumRowHeight Returns the minimum row height for the specified row in this table entity.
Public method MoveContent Moves content in the cell from one position to another.
Public method RecomputeTableBlock Updates the block table record referenced by this table entity.
Public method RemoveAllOverrides Removes all overrides in a cell, row or column. Use a valid row index and pass the column index '-1' to remove the row property overrides. Use a valid column index and pass the row index '-1' to remove the column property overrides.
Public method RemoveDataLink Removes all data links.
Public method RemoveDataLink(Int32, Int32) Removes all data link at the specified cell.
Public method ReselectSubRegion Removes all data link at the specified cell.
Public method ResetValue Resets the value in a specified cell.
Public method RowHeight Returns the height of the specified row in this table entity.
Public method RowType Returns the type of the specified row in this table entity.
Public method Select Selects a cell in this table by the specified point, viewing direction, and orientation.
Public method SelectSubRegion Selects a set of cells in this table by the specified window box, viewing direction, and orientation.
Public method SetAlignment(CellAlignment, Int32) Sets the cell alignment for the specified row types in this table entity.
Public method SetAlignment(Int32, Int32, CellAlignment) Sets the cell alignment for the specified row types in this table entity.
Public method SetAutoScale Specifies whether the block in the specified cell in this table entity is automatically scaled and positioned to fit into the cell.
Public method SetBackgroundColor(Color, Int32) Sets the background color for the specified row types in this table entity.
Public method SetBackgroundColor(Int32, Int32, Color) Sets the background color for the specified cell in this table entity.
Public method SetBackgroundColorNone(Boolean, Int32) Specifies whether the background color for the specified row types is disabled for this table entity.
Public method SetBackgroundColorNone(Int32, Int32, Boolean) Specifies whether the background color for the specified cell is disabled for this table entity.
Public method SetBlockAttributeValue(Int32, Int32, ObjectId, String) Sets the attribute value from the block cell using the specified object ID key in this table entity.
Public method SetBlockAttributeValue(Int32, Int32, Int32, ObjectId, String) Sets the attribute value from the block cell using the specified object ID key in this table entity.
Public method SetBlockRotation Sets the rotation angle of the block reference in the specified cell in this table entity.
Public method SetBlockScale Sets the scale factor of the block reference in the specified cell in this table entity.
Public method SetBlockTableRecordId(Int32, Int32, ObjectId, Boolean) Sets the Object ID of the block table record in the specified cell in this table entity.
Public method SetBlockTableRecordId(Int32, Int32, Int32, ObjectId, Boolean) Returns the Object Id of the block table record for the content at the specified content index.
Public method SetBreakHeight Sets the table break height of the specified table entity when table breaking is enabled.
Public method SetBreakOffset Sets the table break offset of the specified table entity when table breaking is enabled.
Public method SetBreakSpacing Returns the break spacing for this table entity.
Public method SetCellState Sets the cell state.
Public method SetCellStyle Sets the cell style. Use a valid row index and pass the column index '-1' to set the style for the row. Use a valid column index and pass the row index '-1' to set the style for the column.
Public method SetCellType Sets the cell type of the specified cell in this table entity.
Public method SetColumnName Sets the column name.
Public method SetColumnWidth(Double) Sets the width of columns in this table entity.
Public method SetColumnWidth(Int32, Double) Sets the width of the specified column in this table entity.
Public method SetContentColor(Color, Int32) Sets the content color for the specified row type in this table entity.
Public method SetContentColor(Int32, Int32, Color) Sets the content color for the specified cell in this table entity.
Public method SetContentColor(Int32, Int32, Int32, Color) Sets the color of the cell content.
Public method SetContentLayout Sets the content layout of the cell.
Public method SetCustomData(Int32, Int32, Int32) Sets the custom data value of the cell, column or row. Use a valid row index and pass the column index '-1' to set custom data for the row. Use a valid column index and pass the row index '-1' to set custom data for the column.
Public method SetCustomData(Int32, Int32, String, Object) Sets the custom data value of the cell, column or row as key-value pair. Use a valid row index and pass the column index '-1' to set custom data for the row. Use a valid column index and pass the row index '-1' to set custom data for the column.
Public method SetDataFormat(Int32, Int32, String) Sets the data format of the cell.
Public method SetDataFormat(Int32, Int32, Int32, String) Sets the data format of the cell at the specified content index.
Public method SetDataLink(CellRange, ObjectId, Boolean) Sets the data link for the specified cell range.
Public method SetDataLink(Int32, Int32, ObjectId, Boolean) Sets the data link for the specified cell range.
Public method SetDataType(DataType, UnitType, Int32) Sets the data type and unit type for the specified row types.
Public method SetDataType(Int32, Int32, Int32, DataTypeParameter) Sets the data type and unit type for the specified cell.
Public method SetDataType(Int32, Int32, DataType, UnitType) Sets the data type and unit type for the specified cell.
Public method SetFieldId(Int32, Int32, ObjectId) Sets the field for the specified cell in this table entity.
Public method SetFieldId(Int32, Int32, Int32, ObjectId, CellOption) Sets the field for the specified content in a cell in this table entity.
Public method SetFormat(String, Int32) Sets the row format type.
Public method SetFormat(Int32, Int32, String) Sets the cell format type.
Public method SetFormula Sets the formula at the specified content index of the cell.
Public method SetGridColor(Color, Int32, Int32) Sets the grid color for the specified gridline types and row type in this table entity.
Public method SetGridColor(Int32, Int32, Int16, Color) Sets the grid color for the specified cell and edges in this table entity.
Public method SetGridColor(Int32, Int32, GridLineType, Color) Sets the grid color of the cell, row or column. Use a valid row index and pass the column index '-1' to get the row grid line color. Use a valid column index and pass the row index '-1' to get the column grid line color.
Public method SetGridDoubleLineSpacing Sets the grid double line spacing of the cell, row or column. Use a valid row index and pass the column index '-1' to set the row grid double line spacing. Use a valid column index and pass the row index '-1' to set the column grid double line spacing.
Public method SetGridLineStyle Sets the grid linestyle of a cell, row or column. Use a valid row index and pass the column index '-1' to set the row grid line style. Use a valid column index and pass the row index '-1' to set the column grid line style.
Public method SetGridLinetype Sets the grid linetype of the cell, row or column. Use a valid row index and pass the column index '-1' to set the row grid linetype. Use a valid column index and pass the row index '-1' to set the column grid linetype.
Public method SetGridLineWeight(LineWeight, Int32, Int32) Sets the grid lineweight for the specified gridline types and row types in this table entity.
Public method SetGridLineWeight(Int32, Int32, Int16, LineWeight) Sets the grid lineweight for the specified cell and edges in this table entity.
Public method SetGridLineWeight(Int32, Int32, GridLineType, LineWeight) Sets the grid lineweight of a cell, row or column. Use a valid row index and pass the column index '-1' to set the row grid lineweight. Use a valid column index and pass the row index '-1' to set the column grid lineweight.
Public method SetGridProperty(CellRange, GridLineType, GridPropertyParameter) Sets the grid line property of the cell, row or column.
Public method SetGridProperty(Int32, Int32, GridLineType, GridPropertyParameter) Sets the grid line property parameter of the cell, row or column. Use a valid row index and pass the column index '-1' to set the row grid line property parameter. Use a valid column index and pass the row index '-1' to set the column grid line property parameter.
Public method SetGridVisibility(Boolean, Int32, Int32) Sets the grid visibility for the specified gridline type and row type in this table entity.
Public method SetGridVisibility(Int32, Int32, Int16, Boolean) Sets the grid visibility for the specified cell and edges in this table entity.
Public method SetGridVisibility(Int32, Int32, GridLineType, Visibility) Sets the grid visibility for the specified cell and edges in this table entity.
Public method SetIsAutoScale Specifies whether data in the cell is auto-scaled.
Public method SetMargin Sets the margin of the cell, row or column as a double value. Use a valid row index and pass the column index '-1' to get the margin for the row. Use a valid column index and pass the row index '-1' to get the margin for the column.
Public method SetMergeAllEnabled Specifies whether the merge-all flag is enabled for the cell, row or column.
Public method SetOverrides(Int32, Int32, Int32, CellProperties) Sets the override in the grid line of the cell, row or column. Use a valid row index and pass the column index '-1' to get the row property override. Use a valid column index and pass the row index '-1' to get the column property override.
Public method SetOverrides(Int32, Int32, GridLineType, CellProperties) Sets the override in the grid line of the cell, row or column. Use a valid row index and pass the column index '-1' to set the row property override. Use a valid column index and pass the row index '-1' to set the column property override.
Public method SetRotation Sets the content rotation angle in radians.
Public method SetRowHeight(Double) Sets the height of all rows in this table entity.
Public method SetRowHeight(Int32, Double) Sets the height of the specified row in this table entity.
Public method SetScale Sets the scale value of the cell.
Public method SetSize Sets the size for this table entity.
Public method SetTextHeight(Double, Int32) Sets the text height for the specified row types.
Public method SetTextHeight(Int32, Int32, Double) Sets the text height for the specified cell.
Public method SetTextHeight(Int32, Int32, Int32, Double) Sets the text height for the specified cell at the specified content index.
Public method SetTextRotation Sets the text rotation angle of the text in the specified cell in this table entity.
Public method SetTextString(Int32, Int32, String) Sets the text string of the cell.
Public method SetTextString(Int32, Int32, Int32, String) Sets the text string of the cell.
Public method SetTextStyle(ObjectId, Int32) Sets the text style for the specified row types.
Public method SetTextStyle(Int32, Int32, ObjectId) Sets the text style for the specified cell.
Public method SetTextStyleId Sets the text style for the specified cell at the specified content index.
Public method SetToolTip Sets the tooltip of the cell.
Public method SetValue(Int32, Int32, Object) Sets the value of the cell.
Public method SetValue(Int32, Int32, Int32, Object) Sets the value of the cell at the specified content index of the cell.
Public method SetValue(Int32, Int32, String, ParseOption) Sets the value of the first content of a cell.
Public method SetValue(Int32, Int32, Int32, Object, ParseOption) Sets the value of the cell at the specified content index of the cell.
Public method SetValue(Int32, Int32, Int32, String, ParseOption) Sets the value of the cell at the specified content index of the cell.
Public method SuppressRegenerateTable This method allows the user to disable the regeneration of the table block during property changes.
Public method TableStyleOverrides Returns the table style overrides for this table entity.
Public method TextHeight(RowType) Returns the text height of the specified row type.
Public method TextHeight(Int32, Int32) Returns the text height of the specified cell.
Public method TextRotation Sets the text rotation angle of the text in the specified cell in this table entity.
Public method TextString(Int32, Int32) Returns the text string of the cell.
Public method TextString(Int32, Int32, FormatOption) Returns the text string of the cell.
Public method TextStringConst Returns the text string of the cell.
Public method TextStyle(RowType) Returns the text style for the specified row type.
Public method TextStyle(Int32, Int32) Returns the text style for the specified cell.
Public method UnitType(RowType) Returns the unit type of the specified row type.
Public method UnitType(Int32, Int32) Returns the unit type for the specified cell.
Public method UnmergeCells Unmerges a rectangular region of cells in this table entity.
Public method UpdateDataLink(UpdateDirection, UpdateOption) Updates the data link in the table.
Public method UpdateDataLink(Int32, Int32, UpdateDirection, UpdateOption) Updates the data link of the cell.
Public method Value Returns the content value of the specified cell.
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.