CylinderSet(Double, Point3d, Vector3d,
Vector3d, Interval, Double, Double) Method
|
Sets the specified parameters for this
cylinder.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Set(
double radius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
Interval height,
double startAngle,
double endAngle
)
Public Sub Set (
radius As Double,
origin As Point3d,
axisOfSymmetry As Vector3d,
referenceAxis As Vector3d,
height As Interval,
startAngle As Double,
endAngle As Double
)
public:
void Set(
double radius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
Interval^ height,
double startAngle,
double endAngle
)
member Set :
radius : float *
origin : Point3d *
axisOfSymmetry : Vector3d *
referenceAxis : Vector3d *
height : Interval *
startAngle : float *
endAngle : float -> unit
Parameters
- radius Double
- [in] Radius of this cylinder.
- origin Point3d
- [in] A point on the axis of symmetry.
- axisOfSymmetry Vector3d
- [in] Axis of symmetry (rotation).
- referenceAxis Vector3d
- [in] Defines the 0 angle of the cylinder rotation.
- height Interval
- [in] Height interval of this cylinder.
- startAngle Double
-
- endAngle Double
-
See Also