Shape(Point3d, Double, Double, Double) Constructor
|
Constructor for the Shape class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Shape(
Point3d position,
double size,
double rotation,
double widthFactor
)
Public Sub New (
position As Point3d,
size As Double,
rotation As Double,
widthFactor As Double
)
public:
Shape(
Point3d position,
double size,
double rotation,
double widthFactor
)
new :
position : Point3d *
size : float *
rotation : float *
widthFactor : float -> Shape
Parameters
- position Point3d
- [in] Position of the shape entity.
- size Double
- [in] Size of the shape entity.
- rotation Double
- [in] Rotation of the shape entity.
- widthFactor Double
- [in] Relative X scale factor of the shape entity.
See Also