Matrix2dInfoIsEqualTo(Matrix2dInfo,
Tolerance) Method
|
Compares this object to another object within
a specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsEqualTo(
Matrix2dInfo a,
Tolerance tolerance
)
Public Function IsEqualTo (
a As Matrix2dInfo,
tolerance As Tolerance
) As Boolean
public:
bool IsEqualTo(
Matrix2dInfo a,
Tolerance tolerance
)
member IsEqualTo :
a : Matrix2dInfo *
tolerance : Tolerance -> bool
Parameters
- a Matrix2dInfo
- [in] Object to check.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Boolean
true if: * Scale factors are equal * Angles of rotation are equal *
Both matrices have a mirror component present or absent *
Directions of reflection are equal
See Also