Matrix2dInfo Structure

This value type stores the data returned by the Matrix2d.IsConformal() method.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryMatrix2dInfo

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Matrix2dInfo

The Matrix2dInfo type exposes the following members.

Properties
  Name Description
Public property Angle  
Public property IsMirror  
Public property Reflex  
Public property Scale  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo(Matrix2dInfo) Compares this object to another object.
Public method IsEqualTo(Matrix2dInfo, Tolerance) Compares this object to another object within a specified tolerance.
Public method ToString
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider)  
Top
Operators
  Name Description
Public operatorStatic member Equality(Matrix2dInfo, Matrix2dInfo) Equality operator for the Matrix2dInfo structure. Compares input objects for equality.
Public operatorStatic member Inequality(Matrix2dInfo, Matrix2dInfo) Inequality operator for the Matrix2dInfo structure. Compares input objects for inequality.
Top
See Also

©  Bricsys NV. All rights reserved.