SurfaceCreateInterferenceObjects
Method
|
Creates new entities that represent the result
of interference between the surface and specified entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Entity[] CreateInterferenceObjects(
Entity ent,
int flags
)
Public Overridable Function CreateInterferenceObjects (
ent As Entity,
flags As Integer
) As Entity()
public:
virtual array<Entity^>^ CreateInterferenceObjects(
Entity^ ent,
int flags
)
abstract CreateInterferenceObjects :
ent : Entity *
flags : int -> Entity[]
override CreateInterferenceObjects :
ent : Entity *
flags : int -> Entity[]
Parameters
- ent Entity
- [in] The entity the surface must be interfered with.
- flags Int32
- [in] Interference flags.
Return Value
Entity
Array of interference entities.
Remarks
This method is
implemented only for the Spatial modeler. If interference entities
are not created, the method throws the eNoIntersection exception.
The method throws the eInvalidInput exception if an unsupported
entity or NULL is provided as a value of ent.
See Also