GeometryPushModelTransform(Matrix3d)
Method
|
Pushes a model transformation matrix for the
current transformation stack. The specified transformation is
concatenated to the current model transformation (which is
initially the identity transform). The resulting model
transformation is subsequently applied to all geometry introduced
into this vectorization context, until popModelTransform() is
called.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool PushModelTransform(
Matrix3d matrix
)
Public MustOverride Function PushModelTransform (
matrix As Matrix3d
) As Boolean
public:
virtual bool PushModelTransform(
Matrix3d matrix
) abstract
abstract PushModelTransform :
matrix : Matrix3d -> bool
Parameters
- matrix Matrix3d
- [in] Transformation matrix.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
See Also