PlotSettingsValidatorSetClosestMediaName
Method
|
Sets the media name closest to the specified
parameters for the specified PlotSettings object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetClosestMediaName(
PlotSettings plotSet,
double paperWidth,
double paperHeight,
PlotPaperUnit units,
bool matchPrintableArea
)
Public Sub SetClosestMediaName (
plotSet As PlotSettings,
paperWidth As Double,
paperHeight As Double,
units As PlotPaperUnit,
matchPrintableArea As Boolean
)
public:
void SetClosestMediaName(
PlotSettings^ plotSet,
double paperWidth,
double paperHeight,
PlotPaperUnit units,
bool matchPrintableArea
)
member SetClosestMediaName :
plotSet : PlotSettings *
paperWidth : float *
paperHeight : float *
units : PlotPaperUnit *
matchPrintableArea : bool -> unit
Parameters
- plotSet PlotSettings
- [in] PlotSettings object.
- paperWidth Double
- [in] Paper width.
- paperHeight Double
- [in] Paper height.
- units PlotPaperUnit
- [in] Plot paper units.
- matchPrintableArea Boolean
- [in] True to match against printable area, otherwise matches
the physical media size.
Remarks
The plot paper
units determine the units of the margins, offsets, paper size, and
drawing units. plotPaperUnits must be one of the following: Name
Value Description Inches 0 Inches Millimeters 1 Millimeters Pixels
2 Pixels
See Also